Published on: November 2026
DESIGN AND IMPLEMENTATION OF A ZERO TRUST API GATEWAY FOR SECURE AND RISK-AWARE API ACCESS
Angshuman Banerjee Arshadali M. Athani Basappa Veerappa Mohammed Shazaan Aarish
Dr. Annie Sujith
Article Status
Available Documents
Abstract
Keywords— Zero Trust Architecture; API Gateway; API Security; Risk-Based Access Control; Web Application Firewall; Anomaly Detection
How to Cite this Paper
Banerjee, A., Athani, A. M., Veerappa, B. & Aarish, M. S. (2026). Design and Implementation of a Zero Trust API Gateway for Secure and Risk-Aware API Access. International Journal of Creative and Open Research in Engineering and Management, <i>02</i>(11), 1-9. https://doi.org/10.55041/ijcope.v2i11.027
Banerjee, Angshuman, et al.. "Design and Implementation of a Zero Trust API Gateway for Secure and Risk-Aware API Access." International Journal of Creative and Open Research in Engineering and Management, vol. 02, no. 11, 2026, pp. 1-9. doi:https://doi.org/10.55041/ijcope.v2i11.027.
Banerjee, Angshuman,Arshadali Athani,Basappa Veerappa, and Mohammed Aarish. "Design and Implementation of a Zero Trust API Gateway for Secure and Risk-Aware API Access." International Journal of Creative and Open Research in Engineering and Management 02, no. 11 (2026): 1-9. https://doi.org/https://doi.org/10.55041/ijcope.v2i11.027.
References
[1] S. W. Rose, O. Borchert, S. Mitchell, and S. Connelly, “Zero Trust Architecture,” NIST Special Publication 800-207, National Institute of Standards and Technology, 2020. doi: 10.6028/NIST.SP.800-207.[2] R. Chandramouli and Z. Butcher, “A Zero Trust Architecture Model for Access Control in Cloud-Native Applications in Multi-Location Environments,” NIST Special Publication 800-207A, National Institute of Standards and Technology, 2023. doi: 10.6028/NIST.SP.800-207A.
[3] D. Hardt, “The OAuth 2.0 Authorization Framework,” RFC 6749, Internet Engineering Task Force, 2012. doi: 10.17487/RFC6749.
[4] M. Jones, J. Bradley, and N. Sakimura, “JSON Web Token (JWT),” RFC 7519, Internet Engineering Task Force, 2015. doi: 10.17487/RFC7519.
[5] M. Jones, B. Campbell, and N. Sakimura, “JSON Web Token Best Current Practices,” RFC 8725, Internet Engineering Task Force, 2020. doi: 10.17487/RFC8725.
[6] OWASP Foundation, “OWASP API Security Top 10—2023,” OWASP Foundation, 2023.
[7] R. Xu, W. Jin, and D. Kim, “Microservice Security Agent Based on API Gateway in Edge Computing,” Sensors, vol. 19, no. 22, Art. no. 4905, 2019. doi: 10.3390/s19224905.
[8] M. Jones and D. Recordon, “The OAuth 2.0 Authorization Framework: Bearer Token Usage,” RFC 6750, Internet Engineering Task Force, 2012. doi: 10.17487/RFC6750.
[9] Arshadali04, “Zero Trust Secure API Gateway,” GitHub repository. [Online]. Available: https://github.com/Arshadali04/zero-trust-secure-api-gateway. Accessed: Nov. 5, 2026.
[10] Arshadali04, “CI workflow run 36636728497,” GitHub Actions, Sep. 29, 2026. [Online]. Available: https://github.com/Arshadali04/zero-trust-secure-api-gateway/actions/runs/36636728497.
Ethical Compliance & Review Process
- •All submissions are screened under plagiarism detection.
- •Review follows editorial policy.
- •Authors retain copyright.
- •Peer Review Type: Double-Blind Peer Review
- •Published on: Nov 07 2026
This article is licensed under a Creative Commons Attribution-NonCommercial 4.0 International License. You are free to share and adapt this work for non-commercial purposes with proper attribution.

